Page tree
Skip to end of metadata
Go to start of metadata

Debug Certificate expired on XX.XX.XX NN:NN - Unknown Android Packaging Problem

http://javadude.wordpress.com/2010/09/28/eclipse-throws-debug-certificate-expired/

 

 

The 'java' plugin has been applied, but it is not compatible with the Android plugins.

Es ist immer eine gute Idee, im Fehlerfall gradle mit --stacktrace und --info aufzurufen (=> kurz: -is).

Fehlergrund #1

in der build.gradle ist fälschlicherweise tatsächlich das 'java' gradle plugin eingebunden! Das ist leider falsch. Android builds nutzen immer

build.gradle
# RICHTIG
apply plugin: 'com.android.application'

# FALSCH! raus damit!
apply plugin: 'java'

 

Fehlergrund #2

Der Fehler tritt meiner Erfahrung nach auch auf, wenn es eine Fehlkonfiguration in gradle gibt, beispielsweise weil in globalen Konfigurationen (siehe ~/.gradle/) beispielsweise überladene Repository Konfigurationen gibt uns so einige Abhängigkeiten nicht aufgelöst werden können. Das kann natürlich auch passieren, wenn die Internetverbindung restriktiert und bestimmte Ressourcen nicht erreicht werden können.

Auch hier: bestenfalls mal mit ./gradlew -is clean build nachschauen was eigentlich fehl schlägt ,)

  • No labels